Visit routing is occurring on a delayed basis
Incident Report for Doctor On Demand
Resolved
This incident has been resolved.
Posted Nov 09, 2017 - 10:58 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 09, 2017 - 09:22 PST
Investigating
We are currently investigating this issue.
Posted Nov 09, 2017 - 08:59 PST